Apache httpOnly Cookie Disclosure

Description

Apache HTTP Server 2.2.x through 2.2.21 does not properly restrict header information during construction of Bad Request (aka 400) error documents, which allows remote attackers to obtain the values of HTTPOnly cookies via vectors involving a (1) long or (2) malformed header in conjunction with crafted web script.

Affected Apache versions (up to 2.0.21).

ShareShare on FacebookTweet about this on TwitterShare on Google+

Impact
Information disclosure.

Recommendation
Upgrade Apache 2.x to the latest version. Apache 2.2.22 is the first version that fixed this issue.

References
Fixed in Apache httpd 2.2.22
Apache HTTP Server 'httpOnly' Cookie Information Disclosure Vulnerability