Adobe Acrobat Multiple Vulnerabilities April-2012 (Mac OS X)

This host is installed with Adobe Acrobat and is prone to multiple vulnerabilities.
Successful exploitation will let attackers to bypass certain security restrictions, execute arbitrary code via unspecified vectors or cause a denial of service. Impact Level: System/Application
Upgrade to Adobe Acrobat version 9.5.1 or 10.1.3 on later, For updates refer to
The flaws are due to - An unspecified error when handling JavaScript/JavaScript API can be exploited to corrupt memory. - An integer overflow error when handling True Type Font (TTF) can be exploited to corrupt memory. - The application loads executables (msiexec.exe) in an insecure manner.
Adobe Acrobat version 9.x to 9.5 and prior and 10.x to 10.1.2 on Mac OS X