Asterisk SIP Channel Driver Denial Of Service Vulnerability (Linux)

This host has Asterisk installed and is prone to Denial of Service vulnerability.
Successful exploitation will let the attacker cause Denial of Service in the victim's system. Impact Level: Application
Upgrade to version 1.2.34,,, or apply the patch ***** NOTE: Please ignore the warning if the patch is applied. *****
The flaw is due to an error in SIP channel driver which fails to use maximum width when invoking 'sscanf' style functions. This can be exploited via SIP packets containing large sequences of ASCII decimal characters as demonstrated via vectors related to the CSeq value in a SIP header, large Content-Length value and SDP.
Asterisk version 1.2.x before 1.2.34, 1.4.x before, 1.6.0.x before, and 1.6.1.x before on Linux.