Kerio WebMail v5 multiple flaws

The remote host is running version 5 of the Kerio MailServer. There are multiple flaws in this interface which may allow an attacker with a valid webmail account on this host to obtain a shell on this host or to perform a cross-site-scripting attack against this host with version prior to 5.6.4. Version of MailServer prior to 5.6.5 are also prone to a enial of service condition when an incorrect login to the admin console occurs. This could cause the server to crash. Version of MailServer prior to 5.7.7 is prone to a remotely exploitable buffer overrun condition. This vulnerability exists in the spam filter component. If successfully exploited, this could permit remote attackers to execute arbitrary code in the context of the MailServer software. This could also cause a denial of service in the server. *** This might be a false positive, as OVS did not have *** the proper credentials to determine if the remote Kerio *** is affected by this flaw.
Upgrade to Kerio MailServer 5.7.7 or newer