MiniShare webserver buffer overflow

MiniShare 1.4.1 and prior versions are affected by a buffer overflow flaw. A remote attacker could execute arbitrary commands by sending a specially crafted file name in a the GET request. Version 1.3.4 and below do not seem to be vulnerable.
Upgrade to MiniShare 1.4.2 or higher.