MySQL Multiple Vulnerabilities

The host is running MySQL and is prone to multiple vulnerabilities.
Successful exploitation could allow users to cause a denial of service and to execute arbitrary code. Impact Level: Application
Upgrade to MySQL version 5.0.91 or 5.1.47, For updates refer to
The flaws are due to: - An error in 'my_net_skip_rest()' function in 'sql/' when handling a large number of packets that exceed the maximum length, which allows remote attackers to cause a denial of service (CPU and bandwidth consumption). - buffer overflow when handling 'COM_FIELD_LIST' command with a long table name, allows remote authenticated users to execute arbitrary code. - directory traversal vulnerability when handling a '..' (dot dot) in a table name, which allows remote authenticated users to bypass intended table grants to read field definitions of arbitrary tables.
MySQL 5.0.x before 5.0.91 and 5.1.x before 5.1.47 on all running platform.