nginx 'ngx_http_mp4_module.c' Buffer Overflow Vulnerability

nginx is prone to a buffer-overflow vulnerability because it fails to perform adequate boundary checks on user-supplied data. Attackers may leverage this issue to execute arbitrary code in the context of the application. Failed attacks will cause denial-of- service conditions. nginx versions 1.1.3 through 1.1.18 and 1.0.7 through 1.0.14 are vulnerable other versions may also be affected.
Updates are available. Please see the references for more information.