Description
For RocketMQ versions 5.1.0 and below, under certain conditions, there is a risk of remote command execution. Several components of RocketMQ, including NameServer, Broker, and Controller, are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function to execute commands as the system users that RocketMQ is running as. Additionally, an attacker can achieve the same effect by forging the RocketMQ protocol content. To prevent these attacks, users are recommended to upgrade to version 5.1.1 or above for using RocketMQ 5.x or 4.9.6 or above for using RocketMQ 4.x .
Remediation
References
http://packetstormsecurity.com/files/173339/Apache-RocketMQ-5.1.0-Arbitrary-Code-Injection.html
http://www.openwall.com/lists/oss-security/2023/07/12/1
https://github.com/jakabakos/CVE-2023-33246_Apache_RocketMQ_RCE
https://github.com/Malayke/CVE-2023-33246_RocketMQ_RCE_EXPLOIT
https://lists.apache.org/thread/1s8j2c8kogthtpv3060yddk03zq0pxyp
https://www.vicarius.io/vsociety/posts/rocketmq-rce-cve-2023-33246-33247
Related Vulnerabilities
CVE-2022-39218 Vulnerability in npm package @fastly/js-compute
CVE-2021-23346 Vulnerability in maven package org.webjars.npm:html-parse-stringify2
CVE-2017-16138 Vulnerability in npm package mime
CVE-2020-7736 Vulnerability in npm package bmoor
CVE-2023-44487 Vulnerability in maven package org.eclipse.jetty.http2:http2-common