Description
Fixed in Apache httpd 2.2.3:
-
important: mod_rewrite off-by-one error CVE-2006-3747
An off-by-one flaw exists in the Rewrite module, mod_rewrite. Depending on the manner in which Apache httpd was compiled, this software defect may result in a vulnerability which, in combination with certain types of Rewrite rules in the web server configuration files, could be triggered remotely. For vulnerable builds, the nature of the vulnerability can be denial of service (crashing of web server processes) or potentially allow arbitrary code execution.
Affected Apache versions (up to 2.2.2).
Remediation
Upgrade Apache 2.x to the latest version.
References
Related Vulnerabilities
WordPress Plugin MiniMax-Page Layout Builder Cross-Site Scripting (1.3.4)
PHP Improper Control of Generation of Code ('Code Injection') Vulnerability (CVE-2006-0207)
WordPress Plugin Bangla Sidebar Login Cross-Site Scripting (1.0)
WordPress Plugin Sketchus Pricing Tables Unspecified Vulnerability (2.0)