Apache httpd remote denial of service

Description
  • A denial of service vulnerability has been found in the way the multiple overlapping ranges are handled by the Apache HTTPD server: <br/><br/> http://seclists.org/fulldisclosure/2011/Aug/175 <br/><br/> An attack tool is circulating in the wild. Active use of this tools has been observed. The attack can be done remotely and with a modest number of requests can cause very significant memory and CPU usage on the server. <br/><br/> <div class="bb-coolbox"><span class="bb-dark">This alert was generated using only banner information. It may be a false positive. </span></div><br/>Affected Apache versions (1.3.x, 2.0.x through 2.0.64, and 2.2.x through 2.2.19).</span><br/>
Remediation
  • Upgrade to the latest version of Apache HTTP Server (2.2.20 or later), available from the Apache HTTP Server Project Web site.
References