Apache Tomcat version older than 6.0.6

Description

This alert was generated using only banner information. It may be a false positive.

Fixed in Apache Tomcat 6.0.6:
  • low: Cross-site scripting CVE-2007-1358
    Web pages that display the Accept-Language header value sent by the client are susceptible to a cross-site scripting attack if they assume the Accept-Language header value conforms to RFC 2616. Under normal circumstances this would not be possible to exploit, however older versions of Flash player were known to allow carefully crafted malicious Flash files to make requests with such custom headers. Tomcat now ignores invalid values for Accept-Language headers that do not conform to RFC 2616.

Affected Apache Tomcat version (6.0.0 - 6.0.5).

Remediation

Upgrade Apache Tomcat to the latest version.

References