Apache Tomcat version older than 6.0.6

Description
  • <div class="bb-coolbox"><span class="bb-dark">This alert was generated using only banner information. It may be a false positive. </span></div><br/><strong>Fixed in Apache Tomcat 6.0.6:</strong><br/><ul> <li> <strong>low</strong>: Cross-site scripting CVE-2007-1358<br/> Web pages that display the Accept-Language header value sent by the client are susceptible to a cross-site scripting attack if they assume the Accept-Language header value conforms to RFC 2616. Under normal circumstances this would not be possible to exploit, however older versions of Flash player were known to allow carefully crafted malicious Flash files to make requests with such custom headers. Tomcat now ignores invalid values for Accept-Language headers that do not conform to RFC 2616. </li> </ul><br/> <span class="bb-navy">Affected Apache Tomcat version (6.0.0 - 6.0.5).</span><br/>
Remediation
  • Upgrade Apache Tomcat to the latest version.
References