Description
Drupal Core is prone to a form action attribute injection vulnerability because it fails to properly verify user-supplied input. An attacker may leverage this issue to redirect Drupal form submissions to a third-party site under his control, thus gaining access to sensitive information such as e-mail addresses and possible other private profile data. Drupal Core versions 4.7.x ranging from 4.7.0 and up to and including 4.7.3 are vulnerable.
Remediation
Update to Drupal Core version 4.7.4 or latest
References
Related Vulnerabilities
Oracle JRE CVE-2017-10295 Vulnerability (CVE-2017-10295)
XWiki Missing Authentication for Critical Function Vulnerability (CVE-2022-24820)
MySQL CVE-2019-2587 Vulnerability (CVE-2019-2587)
WordPress Plugin MAZ Loader-Preloader Builder for WordPress SQL Injection (1.3.2)
WordPress Plugin Secure HTML5 Video Player Cross-Site Scripting (3.3)