Drupal Core 5.x Multiple Vulnerabilities (5.0 - 5.9)

Description

Drupal Core is prone to multiple vulnerabilities, including cross-site scripting, cross-site request forgery and arbitrary file upload vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to perform certain administrative actions and gain unauthorized access to the affected application or to upload arbitrary code and run it in the context of the webserver process, which may facilitate unauthorized access or privilege escalation. Drupal Core versions 5.x ranging from 5.0 and up to and including 5.9 are vulnerable.

Remediation

Update to Drupal Core version 5.10 or latest

References