Drupal Core 6.x Multiple Vulnerabilities (6.0 - 6.2)

Description

Drupal Core is prone to multiple vulnerabilities, including cross-site scripting, cross-site request forgery, session fixation and SQL injection vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to perform certain administrative actions and gain unauthorized access to the affected application, to hijack an arbitrary session and gain access to sensitive information or to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database. Drupal Core versions 6.x ranging from 6.0 and up to and including 6.2 are vulnerable.

Remediation

Update to Drupal Core version 6.3 or latest

References