Drupal Core 6.x Multiple Vulnerabilities (6.0 - 6.3)

Description

Drupal Core is prone to multiple vulnerabilities, including cross-site scripting, cross-site request forgery, security bypass and arbitrary file upload vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to perform certain administrative actions and gain unauthorized access to the affected application, to perform otherwise restricted actions and subsequently edit nodes, delete any file to which the webserver has sufficient rights or download attachments of nodes, or to upload arbitrary code and run it in the context of the webserver process, which may facilitate unauthorized access or privilege escalation. Drupal Core versions 6.x ranging from 6.0 and up to and including 6.3 are vulnerable.

Remediation

Update to Drupal Core version 6.4 or latest

References