Drupal Core is prone to multiple vulnerabilities, including cross-site scripting, open redirect, security bypass, cryptographic weakness and code execution vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to redirect users to arbitrary web sites and conduct phishing attacks, to perform otherwise restricted actions and subsequently bypass access controls using invalid tokens, to predict security related strings used in several core modules, to execute arbitrary commands with the privileges of the user running the application, to compromise the application or the underlying database, to access or modify data or to compromise a vulnerable system. Drupal Core versions 7.x ranging from 7.0 and up to and including 7.23 are vulnerable.


Update to Drupal Core version 7.24 or latest


Related Vulnerabilities