Description
Drupal Core is prone to multiple vulnerabilities, including cross-site scripting, security bypass and arbitrary code execution vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, to perform otherwise restricted actions and subsequently authenticate as a different user, to execute arbitrary commands with the privileges of the user running the application, to compromise the application or the underlying database, to access or modify data or to compromise a vulnerable system. Drupal Core versions 8.5.x ranging from 8.5.0 and up to and including 8.5.14 are vulnerable.
Remediation
Update to Drupal Core version 8.5.15 or latest
References
Related Vulnerabilities
MediaWiki Exposure of Resource to Wrong Sphere Vulnerability (CVE-2021-31554)
ReviveAdserver Permissions, Privileges, and Access Controls Vulnerability (CVE-2015-7371)
WordPress Plugin WP-Members Membership Multiple Cross-Site Scripting Vulnerabilities (2.8.9)
Jenkins Allocation of Resources Without Limits or Throttling Vulnerability (CVE-2023-27901)
Moodle Permissions, Privileges, and Access Controls Vulnerability (CVE-2012-3391)