Joomla! Core is prone to multiple vulnerabilities, including cross-site scripting and SQL injection vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials or to compromise the application, access or modify data, or exploit latent vulnerabilities in the underlying database. Joomla! Core versions 1.0.x ranging from 1.0.0 and up to and including 1.0.9 are vulnerable.
Update to Joomla! Core version 1.0.10 or latest