Description
Joomla! Core is prone to a remote file inclusion vulnerability because it fails to properly verify user-supplied input. An attacker can exploit this issue to include arbitrary remote files containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and to gain access to the underlying system. Joomla! Core versions 2.5.x ranging from 2.5.4 and up to and including 2.5.25 are vulnerable.
Remediation
Update to Joomla! Core version 2.5.26 or latest
References
https://www.exploit-db.com/exploits/35033/
https://www.akeebabackup.com/home/news/1605-security-update-sep-2014.html
https://developer.joomla.org/security/595-20140903-core-remote-file-inclusion.html
Related Vulnerabilities
Joomla Cryptographic Issues Vulnerability (CVE-2008-4122)
Jboss EAP Uncontrolled Resource Consumption Vulnerability (CVE-2020-14384)
Oracle Database Server CVE-2007-2110 Vulnerability (CVE-2007-2110)
MediaWiki CVE-2022-28206 Vulnerability (CVE-2022-28206)
WordPress 4.8.x Denial of Service Vulnerability (4.8 - 4.8.5)