WordPress 2.0.2 Username Remote PHP Code Injection Vulnerability (0.6.2 - 2.0.2)

Description
  • WordPress is prone to a remote PHP code injection vulnerability because it fails to properly sanitize user-supplied input. Successful exploitation may allow attackers to execute arbitrary code with the privileges of the user running the application, to compromise the application or the underlying database, to access or modify data or to compromise a vulnerable system. For a successful exploit of this issue, the MySQL password used in the application must be either blank or trivial to guess. WordPress versions prior to 2.0.3 are vulnerable.
Remediation
  • Update to WordPress version 2.0.3 or latest
References