- WordPress is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks. Note that this issue only affects IP-based virtual servers running on Apache 2.x. WordPress versions prior to 2.6.5 are vulnerable.
- Update to WordPress version 2.6.5 or latest
- WordPress Plugin WPshop-eCommerce Arbitrary File Upload (184.108.40.206)
- WordPress Plugin AffiliateWP Cross-Site Scripting (2.0.9)
- WordPress Plugin Student Result or Employee Database Security Bypass (1.6.3)
- WordPress Plugin PitchPrint Arbitrary File Upload (7.2.1)
- WordPress Plugin WordApp Mobile App-Convert your WordPress Site to a Mobile App Cross-Site Scripting (2.0.3)