Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting, SQL injection and security bypass vulnerabilities because it fails to properly sanitize user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to compromise the application, access or modify data, to exploit vulnerabilities in the underlying database or to perform otherwise restricted actions. WordPress versions prior to 3.0.2 are vulnerable.
Remediation
Update to WordPress version 3.0.2 or latest
References
http://blog.sjinks.pro/wordpress/858-information-disclosure-via-sql-injection-attack/
http://www.exploit-db.com/exploits/15684/
http://cxsecurity.com/issue/WLB-2010080127
Related Vulnerabilities
MySQL CVE-2015-4904 Vulnerability (CVE-2015-4904)
Drupal Core 7.x Multiple Security Bypass Vulnerabilities (7.0 - 7.25)
Apache Tomcat Loop with Unreachable Exit Condition ('Infinite Loop') Vulnerability (CVE-2020-13935)
WordPress Plugin Listing, Classified Ads & Business Directory-uListing SQL Injection (2.0.3)