Description
WordPress is prone to multiple vulnerabilities, including cross-site scripting and security bypass vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks and to perform otherwise restricted actions and subsequently publish new posts or make unintended plugin changes. WordPress versions prior to 3.4.2 are vulnerable.
Remediation
Update to WordPress version 3.4.2 or latest
References
Related Vulnerabilities
WordPress Plugin TemplatesNext ToolKit Cross-Site Scripting (3.2.8)
WordPress Plugin Easy Coming Soon Cross-Site Scripting (1.6.2)
ATutor Incorrect Authorization Vulnerability (CVE-2019-16114)
MySQL CVE-2014-2484 Vulnerability (CVE-2014-2484)
Moodle Improper Access Control Vulnerability (CVE-2016-2159)