- WordPress is prone to multiple vulnerabilities, including cross-site scripting, security bypass, cross-site request forgery and information disclosure vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to perform certain administrative actions and gain unauthorized access to the affected application or to obtain sensitive information. WordPress versions prior to 3.4.1 are vulnerable.
- Update to WordPress version 3.4.1 or latest
- WordPress Plugin BuddyPress Cross-Site Request Forgery (2.9.0)
- WordPress Plugin Google Doc Embedder SQL Injection (2.5.16)
- WordPress Plugin Category and Page Icons Cross-Site Scripting (0.9.2)
- WordPress Plugin A.M.Y. Cross-Site Scripting (1.3.3)
- WordPress Plugin Simply Static Multiple Vulnerabilities (1.7.0)