WordPress 3.5.1 Multiple Vulnerabilities (2.0 - 3.5.1)

Description
  • WordPress is prone to multiple vulnerabilities, including cross-site scripting, security bypass, server-side request forgery, XML external entity injection, information disclosure and Denial of Service vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials and launch other attacks, to perform otherwise restricted actions and subsequently publish posts or reassign authorship, to make the vulnerable server perform authentication requests to a remote or internal network database which could potentially be used to expose information and compromise a site, to obtain sensitive information or to consume memory and CPU resources, denying service to legitimate users. WordPress versions prior to 3.5.2 are vulnerable.
Remediation
  • Update to WordPress version 3.5.2 or latest
References