Description
WordPress is prone to a prototype pollution vulnerability. Exploiting this issue could allow an attacker to inject key/value �properties� into JavaScript objects, potentially allowing for execution of arbitrary JavaScript in a user�s session if they can trick that user into clicking a link. WordPress versions 4.2.x ranging from 4.2 and up to (and including) 4.2.31 are vulnerable.
Remediation
Update to WordPress version 4.2.32 or latest
References
https://github.com/BlackFan/client-side-prototype-pollution/blob/master/pp/jquery-query-object.md
https://wordpress.org/support/wordpress-version/version-4-2-32/
Related Vulnerabilities
WordPress Improper Authentication Vulnerability (CVE-2008-1930)
XWiki CVE-2023-48241 Vulnerability (CVE-2023-48241)
WordPress 4.3.x Cross-Site Scripting Vulnerability (4.3 - 4.3.1)
PrestaShop Improper Authentication Vulnerability (CVE-2021-21308)
WordPress Plugin Ivory Search-WordPress Search Cross-Site Scripting (4.7.1)