WordPress is prone to multiple vulnerabilities, including cross-site scripting, shortcode execution, information disclosure and Denial of Service via cache poisoning vulnerabilities. Exploiting these issues could allow an attacker to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site, allowing the attacker to steal cookie-based authentication credentials, to execute shortcodes by calling the built-in 'parse-media-shortcode� AJAX handler, to obtain sensitive information or to deny REST API endpoint access to legitimate users. WordPress versions 4.9.x ranging from 4.9 and up to (and including) 4.9.23 are vulnerable.


Update to WordPress version 4.9.24 or latest


Related Vulnerabilities