WordPress Plugin IP Blacklist Cloud Arbitrary File Disclosure (3.42)

Description
  • WordPress Plugin IP Blacklist Cloud is prone to an arbitrary file disclosure vulnerability because it fails to properly sanitize user-supplied input. An attacker can exploit this vulnerability to view local files (eg. server configuration) in the context of the web server process, which may aid in launching further attacks. WordPress Plugin IP Blacklist Cloud version 3.42 is vulnerable; prior versions may also be affected.
Remediation
  • Update to plugin version 3.43 or latest
References