Description
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.
Remediation
References
http://www.securityfocus.com/bid/100823
https://mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/%3CCAEccTyy-1yYuhdNgkBUg0sr9NeaZSrBKkBePdTNZbxXZNTAR-g%40mail.gmail.com%3E
Related Vulnerabilities
CVE-2010-5312 Vulnerability in maven package org.fujion.webjars:jquery-ui
CVE-2020-8131 Vulnerability in npm package yarn
CVE-2018-3752 Vulnerability in npm package merge-options
CVE-2019-3888 Vulnerability in maven package io.undertow:undertow-core
CVE-2020-9296 Vulnerability in maven package com.netflix.conductor:conductor-core