Description
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Remediation
References
http://blog.apps.npr.org/2018/02/15/pym-security-vulnerability.html
https://github.com/nprapps/pym.js
https://github.com/nprapps/pym.js/issues/170
Related Vulnerabilities
CVE-2022-43433 Vulnerability in maven package io.jenkins.plugins:screenrecorder
CVE-2023-35160 Vulnerability in maven package org.xwiki.platform:xwiki-platform-web-templates
CVE-2022-23464 Vulnerability in maven package com.nepxion:discovery-plugin-admin-center
CVE-2022-37435 Vulnerability in maven package org.apache.shenyu:shenyu-admin