Description
auth0.js (NPM package auth0-js) greater than version 8.0.0 and before version 9.12.3 has a vulnerability. In the case of an (authentication) error, the error object returned by the library contains the original request of the user, which may include the plaintext password the user entered. If the error object is exposed or logged without modification, the application risks password exposure. This is fixed in version 9.12.3
Remediation
References
https://github.com/auth0/auth0.js/commit/355ca749b229fb93142f0b3978399b248d710828
https://github.com/auth0/auth0.js/security/advisories/GHSA-prfq-f66g-43mp
Related Vulnerabilities
CVE-2018-19837 Vulnerability in npm package node-sass
CVE-2021-21293 Vulnerability in maven package org.http4s:blaze-core_2.12
CVE-2014-7810 Vulnerability in maven package org.apache.tomcat.embed:tomcat-embed-jasper
CVE-2021-42392 Vulnerability in maven package com.h2database:h2
CVE-2023-0869 Vulnerability in maven package org.opennms:opennms-web-api