Description
Lucee Server is a dynamic, Java based (JSR-223), tag and scripting language used for rapid web application development. In Lucee Admin before versions 5.3.7.47, 5.3.6.68 or 5.3.5.96 there is an unauthenticated remote code exploit. This is fixed in versions 5.3.7.47, 5.3.6.68 or 5.3.5.96. As a workaround, one can block access to the Lucee Administrator.
Remediation
References
http://ciacfug.org/blog/updating-lucee-as-part-of-a-vulnerability-alert-response
http://packetstormsecurity.com/files/163864/Lucee-Administrator-imgProcess.cfm-Arbitrary-File-Write.html
https://dev.lucee.org/t/lucee-vulnerability-alert-november-2020/7643
https://github.com/httpvoid/writeups/blob/main/Apple-RCE.md
https://github.com/lucee/Lucee/commit/6208ab7c44c61d26c79e0b0af10382899f57e1ca
https://github.com/lucee/Lucee/security/advisories/GHSA-2xvv-723c-8p7r
https://portswigger.net/daily-swig/security-researchers-earn-50k-after-exposing-critical-flaw-in-apple-travel-portal
Related Vulnerabilities
CVE-2023-3691 Vulnerability in maven package org.webjars.bowergithub.layui:layui
CVE-2022-35513 Vulnerability in npm package blink1control2
CVE-2014-0050 Vulnerability in maven package org.apache.jackrabbit:oak-run
CVE-2020-15138 Vulnerability in maven package org.webjars.npm:prismjs
CVE-2020-11975 Vulnerability in maven package org.apache.unomi:unomi-common