Description
Applications using Spring Cloud Gateway are vulnerable to specifically crafted requests that could make an extra request on downstream services. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.5+, 2.2.x users should upgrade to 2.2.10.RELEASE or newer.
Remediation
References
https://tanzu.vmware.com/security/cve-2021-22051
Related Vulnerabilities
CVE-2021-31812 Vulnerability in maven package org.apache.pdfbox:pdfbox
CVE-2018-19413 Vulnerability in maven package org.sonarsource.sonarqube:sonar-plugin-api
CVE-2021-21343 Vulnerability in maven package com.thoughtworks.xstream:xstream
CVE-2023-35166 Vulnerability in maven package org.xwiki.platform:xwiki-platform-help-ui