Description
There is a potential heap buffer overflow in Apache Hadoop libhdfs native code. Opening a file path provided by user without validation may result in a denial of service or arbitrary code execution. Users should upgrade to Apache Hadoop 2.10.2, 3.2.3, 3.3.2 or higher.
Remediation
References
https://lists.apache.org/thread/2h56ztcj3ojc66qzf1nno88vjw9vd4wo
https://security.netapp.com/advisory/ntap-20220715-0007/
Related Vulnerabilities
CVE-2021-32573 Vulnerability in npm package express-cart
CVE-2019-10322 Vulnerability in maven package org.jenkins-ci.plugins:artifactory
CVE-2023-40816 Vulnerability in maven package org.opencrx:opencrx-core-models
CVE-2023-30465 Vulnerability in maven package org.apache.inlong:manager-pojo
CVE-2021-21388 Vulnerability in npm package systeminformation