Description
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
Remediation
References
https://github.com/angular/angular/commit/ba8da742e3b243e8f43d4c63aa842b44e14f2b09
https://github.com/angular/angular/issues/40136
https://security.snyk.io/vuln/SNYK-JS-ANGULARCORE-1070902
https://vuldb.com/?id.181356
Related Vulnerabilities
CVE-2021-23664 Vulnerability in npm package @isomorphic-git/cors-proxy
CVE-2022-3171 Vulnerability in maven package com.google.protobuf:protobuf-java
CVE-2019-18213 Vulnerability in maven package org.lsp4xml:org.eclipse.lsp4xml.extensions.web
CVE-2009-2901 Vulnerability in maven package tomcat:catalina
CVE-2014-0120 Vulnerability in maven package io.hawt:hawtio-system