Description
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Remediation
References
https://github.com/nahsra/antisamy/releases/tag/v1.6.6
https://search.maven.org/artifact/net.sourceforge.htmlunit/neko-htmlunit
https://sourceforge.net/projects/htmlunit/files/htmlunit/2.27/
Related Vulnerabilities
CVE-2020-14968 Vulnerability in maven package org.webjars.bowergithub.kjur:jsrsasign
CVE-2020-1714 Vulnerability in maven package org.keycloak:keycloak-common
CVE-2021-28860 Vulnerability in npm package mixme
CVE-2021-41084 Vulnerability in maven package org.http4s:http4s-server_3
CVE-2020-36732 Vulnerability in maven package org.webjars.bower:crypto-js