Description
Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.
Remediation
References
https://lists.apache.org/thread/kr1y4l9752g1ww1shnmh8dbfjq785k4m
Related Vulnerabilities
CVE-2023-50769 Vulnerability in maven package org.sonatype.nexus.ci:nexus-jenkins-plugin
CVE-2020-2182 Vulnerability in maven package org.jenkins-ci.plugins:credentials-binding
CVE-2020-6454 Vulnerability in npm package electron
CVE-2023-34047 Vulnerability in maven package org.springframework.graphql:spring-graphql
CVE-2022-45399 Vulnerability in maven package org.zeroturnaround:cluster-stats