Description
Muhammara is a node module with c/cpp bindings to modify PDF with JavaScript for node or electron. The package muhammara before 2.6.2 and from 3.0.0 and before 3.3.0, as well as all versions of muhammara's predecessor package hummus, are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. The issue has been patched in muhammara version 3.4.0 and the fix has been backported to version 2.6.2. As a workaround, do not process files from untrusted sources. If using hummus, replace the package with muhammara.
Remediation
References
https://github.com/julianhille/MuhammaraJS/pull/235
https://github.com/julianhille/MuhammaraJS/pull/238
https://github.com/julianhille/MuhammaraJS/security/advisories/GHSA-2r7v-cmch-5x26
Related Vulnerabilities
CVE-2017-18214 Vulnerability in npm package moment
CVE-2021-23337 Vulnerability in npm package lodash.template
CVE-2023-44487 Vulnerability in maven package org.eclipse.jetty.http2:http2-common
CVE-2022-46166 Vulnerability in maven package de.codecentric:spring-boot-admin-server
CVE-2020-1719 Vulnerability in maven package org.wildfly.bom:wildfly