Description
Multiple stored and reflected cross-site scripting vulnerabilities in webapp jsp pages in multiple versions of OpenNMS Meridian and Horizon could allow an attacker access to confidential session information. Users should upgrade to Meridian 2023.1.0 or newer, or Horizon 31.0.4. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Remediation
References
https://docs.opennms.com/meridian/2022/releasenotes/changelog.html#releasenotes-changelog-Meridian-2022.1.13
https://github.com/OpenNMS/opennms/pull/5765
Related Vulnerabilities
CVE-2020-7639 Vulnerability in npm package eivindfjeldstad-dot
CVE-2019-13127 Vulnerability in maven package org.webjars.bowergithub.jgraph:mxgraph
CVE-2019-20330 Vulnerability in maven package com.fasterxml.jackson.core:jackson-databind
CVE-2023-32314 Vulnerability in npm package vm2
CVE-2022-41965 Vulnerability in maven package org.opencastproject:opencast-engage-paella-player