Description
In Apache Linkis <=1.3.1, because the parameters are not effectively filtered, the attacker uses the MySQL data source and malicious parameters to configure a new data source to trigger a deserialization vulnerability, eventually leading to remote code execution. Versions of Apache Linkis <= 1.3.0 will be affected. We recommend users upgrade the version of Linkis to version 1.3.2.
Remediation
References
http://www.openwall.com/lists/oss-security/2023/04/10/5
https://lists.apache.org/thread/18vv0m32oy51nzk8tbz13qdl5569y55l
Related Vulnerabilities
CVE-2021-34081 Vulnerability in npm package gitsome
CVE-2021-23597 Vulnerability in npm package fastify-multipart
CVE-2021-32685 Vulnerability in npm package tenvoy
CVE-2019-0219 Vulnerability in npm package cordova-plugin-inappbrowser
CVE-2021-25641 Vulnerability in maven package org.apache.dubbo:dubbo