Description
Incorrect Authorization vulnerability in Apache Software Foundation Apache Pulsar. This issue affects Apache Pulsar: before 2.10.4, and 2.11.0. When a client connects to the Pulsar Function Worker via the Pulsar Proxy where the Pulsar Proxy uses mTLS authentication to authenticate with the Pulsar Function Worker, the Pulsar Function Worker incorrectly performs authorization by using the Proxy's role for authorization instead of the client's role, which can lead to privilege escalation, especially if the proxy is configured with a superuser role. The recommended mitigation for impacted users is to upgrade the Pulsar Function Worker to a patched version. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.4. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.1. 3.0 Pulsar Function Worker users are unaffected. Any users running the Pulsar Function Worker for 2.9.* and earlier should upgrade to one of the above patched versions.
Remediation
References
https://lists.apache.org/thread/v0gcvvxswr830314q4b1kybsfmcf3jf8
Related Vulnerabilities
CVE-2019-1003055 Vulnerability in maven package org.jvnet.hudson.plugins:ftppublisher
CVE-2019-10336 Vulnerability in maven package org.jenkins-ci.plugins:electricflow
CVE-2021-21606 Vulnerability in maven package org.jenkins-ci.main:jenkins-core
CVE-2021-23264 Vulnerability in maven package org.craftercms:crafter-search
CVE-2023-22621 Vulnerability in npm package @strapi/plugin-users-permissions