Description
Improper Privilege Management Vulnerabilities in Apache Software Foundation Apache InLong.This issue affects Apache InLong: from 1.2.0 through 1.6.0. When the attacker has access to a valid (but unprivileged) account, the exploit can be executed using Burp Suite by sending a login request and following it with a subsequent HTTP request using the returned cookie. Users are advised to upgrade to Apache InLong's 1.7.0 or cherry-pick https://github.com/apache/inlong/pull/7836 https://github.com/apache/inlong/pull/7836 to solve it.
Remediation
References
https://lists.apache.org/thread/btorjbo9o71h22tcvxzy076022hjdzq0
Related Vulnerabilities
CVE-2022-22947 Vulnerability in maven package org.springframework.cloud:spring-cloud-gateway
CVE-2020-2202 Vulnerability in maven package org.jenkins-ci.plugins:fortify-on-demand-uploader
CVE-2023-27899 Vulnerability in maven package org.jenkins-ci.main:jenkins-core
CVE-2018-1999020 Vulnerability in maven package org.onosproject:onos-core-common
CVE-2022-28158 Vulnerability in maven package com.surenpi.jenkins:phoenix-autotest