Description
The RocketMQ NameServer component still has a remote command execution vulnerability as the CVE-2023-33246 issue was not completely fixed in version 5.1.1. When NameServer address are leaked on the extranet and lack permission verification, an attacker can exploit this vulnerability by using the update configuration function on the NameServer component to execute commands as the system users that RocketMQ is running as. It is recommended for users to upgrade their NameServer version to 5.1.2 or above for RocketMQ 5.x or 4.9.7 or above for RocketMQ 4.x to prevent these attacks.
Remediation
References
http://www.openwall.com/lists/oss-security/2023/07/12/1
https://lists.apache.org/thread/m614czxtpvlztd7mfgcs2xcsg36rdbnc
Related Vulnerabilities
CVE-2022-29577 Vulnerability in maven package org.owasp:antisamy
CVE-2020-28487 Vulnerability in npm package vis-timeline
CVE-2022-36885 Vulnerability in maven package com.coravy.hudson.plugins.github:github
CVE-2019-10376 Vulnerability in maven package org.jenkins-ci.plugins:jenkinswalldisplay
CVE-2022-25875 Vulnerability in maven package org.webjars.npm:svelte