Description
A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.
Remediation
References
https://docs.opennms.com/horizon/32/releasenotes/changelog.html
https://github.com/OpenNMS/opennms/pull/6368
Related Vulnerabilities
CVE-2023-26049 Vulnerability in maven package org.eclipse.jetty:jetty-server
CVE-2023-26488 Vulnerability in npm package @openzeppelin/contracts
CVE-2016-8747 Vulnerability in maven package org.apache.tomcat.embed:tomcat-embed-core
CVE-2022-36094 Vulnerability in maven package org.xwiki.platform:xwiki-platform-web-templates
CVE-2023-36477 Vulnerability in maven package org.xwiki.contrib:application-ckeditor-ui