Description
Always-Incorrect Control Flow Implementation vulnerability in Apache Tomcat's rewrite valve meant that if the first condition in an OR chain matched, subsequent non-OR conditions were skipped. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Remediation
References
Related Vulnerabilities
WordPress Plugin WP Link To Us Multiple Cross-Site Scripting Vulnerabilities (2.0)
XWiki Inadequate Encryption Strength Vulnerability (CVE-2022-29161)
axios Allocation of Resources Without Limits or Throttling Vulnerability (CVE-2026-44488)
WordPress Plugin Photo Gallery by 10Web-Mobile-Friendly Image Gallery Cross-Site Scripting (1.5.75)