Description
Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the number guess example for Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected. Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Remediation
References
Related Vulnerabilities
WordPress Plugin Video Conferencing with Zoom Cross-Site Scripting (3.8.15)
WordPress Plugin WP eCommerce 'wpsc-transaction_results_functions.php' SQL Injection (3.8.7.5)
PostgreSQL Missing Encryption of Sensitive Data Vulnerability (CVE-2017-7485)
Dolibarr CVE-2023-38886 Vulnerability (CVE-2023-38886)
Moodle Permissions, Privileges, and Access Controls Vulnerability (CVE-2014-0122)