Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
Remediation
References
Related Vulnerabilities
MongoDb Improper Certificate Validation Vulnerability (CVE-2024-1351)
WordPress Plugin NewStatPress Cross-Site Scripting (1.0.5)
WordPress Plugin Leaflet Maps Marker Pro Multiple Vulnerabilities (1.5.7)
WordPress Plugin WPtouch Arbitrary File Upload (3.4.6)
Zope Web Application Server Other Vulnerability (CVE-2006-4684)