Description
Drupal Core is prone to multiple cross-site scripting vulnerabilities because it fails to properly sanitize user-supplied input. An attacker may leverage these issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Drupal Core versions 4.6.x ranging from 4.6.0 and up to and including 4.6.9 are vulnerable.
Remediation
Update to Drupal Core version 4.6.10 or latest
References
Related Vulnerabilities
WordPress Plugin Peter's Login Redirect Multiple Vulnerabilities (2.9.0)
Apache HTTP Server Improper Encoding or Escaping of Output Vulnerability (CVE-2024-38474)
Apache HTTP Server Improper Input Validation Vulnerability (CVE-2024-42516)
WordPress Plugin Form for WordPress-Zoho Forms Cross-Site Scripting (3.0)