Description
Drupal Core is prone to a cross-site scripting vulnerability because it fails to properly sanitize user-supplied input. An attacker may leverage this issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This can allow the attacker to steal cookie-based authentication credentials and launch other attacks. Drupal Core versions 4.7.x ranging from 4.7.0 and up to and including 4.7.10 are vulnerable.
Remediation
Update to Drupal Core version 4.7.11 or latest
References
Related Vulnerabilities
WordPress Plugin Online Hotel Booking System Pro Cross-Site Scripting (1.1)
WordPress Plugin Frontend File Manager Arbitrary File Upload (3.9)
WordPress Plugin Wordfence Security-Firewall & Malware Scan Cross-Site Scripting (6.1.6)
Drupal Permissions, Privileges, and Access Controls Vulnerability (CVE-2008-4792)
WordPress Plugin WP-Live Chat by 3CX Arbitrary File Upload (8.0.31)